using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)(?:<option)([^>]*)( value=""[^""]*"")([^>]*\>|\>)([^>]*)(?:<)";
string input = @"<select id=""OptionToChoose"">
<option value="" selected=""selected"">Choose option</option>
<option></option>
<option value=""1"" class=""1"">Sun</option>
<option class=""2"" value=""2"">Earth</option>
<option class=""3"" selected=""selected"" value=""3"" color=""blue"">Moon</option>
</select>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}