import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)(?:<option)([^>]*)( value=\"[^\"]*\")([^>]*\\>|\\>)([^>]*)(?:<)";
final String string = "<select id=\"OptionToChoose\">\n"
+ " <option value=\"\" selected=\"selected\">Choose option</option>\n"
+ " <option></option>\n"
+ " <option value=\"1\" class=\"1\">Sun</option>\n"
+ " <option class=\"2\" value=\"2\">Earth</option>\n"
+ " <option class=\"3\" selected=\"selected\" value=\"3\" color=\"blue\">Moon</option>\n"
+ "</select>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}