$re = '/(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\>|\>)([^>]*)(?:<)/m';
$str = '<select id="OptionToChoose">
<option value="" selected="selected">Choose option</option>
<option></option>
<option value="1" class="1">Sun</option>
<option class="2" value="2">Earth</option>
<option class="3" selected="selected" value="3" color="blue">Moon</option>
</select>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);