import re
regex = re.compile(r"(?is)(?:<option)([^>]*)( value=\"[^\"]*\")([^>]*\>|\>)([^>]*)(?:<)", flags=re.MULTILINE)
test_str = ("<select id=\"OptionToChoose\">\n"
" <option value=\"\" selected=\"selected\">Choose option</option>\n"
" <option></option>\n"
" <option value=\"1\" class=\"1\">Sun</option>\n"
" <option class=\"2\" value=\"2\">Earth</option>\n"
" <option class=\"3\" selected=\"selected\" value=\"3\" color=\"blue\">Moon</option>\n"
"</select>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")