const regex = /(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\>|\>)([^>]*)(?:<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\\>|\\>)([^>]*)(?:<)', 'gm')
const str = `<select id="OptionToChoose">
<option value="" selected="selected">Choose option</option>
<option></option>
<option value="1" class="1">Sun</option>
<option class="2" value="2">Earth</option>
<option class="3" selected="selected" value="3" color="blue">Moon</option>
</select>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}