// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+").unwrap();
let string = "273385 14093 1522520 1759 277697 283096 1133193 191835 246752 204984 973590";
let substitution = "m#$0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}