import Foundation
let pattern = #"\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"273385 14093 1522520 1759 277697 283096 1133193 191835 246752 204984 973590"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"m#$0"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)