# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\s(\w+)$/$1/gm;t' <<< "The style number is A456RT
Style A456RT
Style number is A456RT"