package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\s(\w+)$`)
var str = `The style number is A456RT
Style A456RT
Style number is A456RT`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}