re = /.*\s(\w+)$/m
str = 'The style number is A456RT
Style A456RT
Style number is A456RT'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result