$re = '/.*\s(\w+)$/m';
$str = 'The style number is A456RT
Style A456RT
Style number is A456RT';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;