use strict;
my $str = 'The style number is A456RT
Style A456RT
Style number is A456RT';
my $regex = qr/.*\s(\w+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";