#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*\s(\w+)$"
Local $sString = "The style number is A456RT" & @CRLF & _
"Style A456RT" & @CRLF & _
"Style number is A456RT"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)