const regex = /.*\s(\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s(\\w+)$', 'gm')
const str = `The style number is A456RT
Style A456RT
Style number is A456RT`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);