using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\s(\w+)$";
string substitution = @"$1";
string input = @"The style number is A456RT
Style A456RT
Style number is A456RT";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}