#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>(?![^а-я]+строк[^а-я]+).)*$"
Local $sString = "только чистое слово: строк или "строк"" & @CRLF & _
"А ниже слова содержащие слово "строк" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:" & @CRLF & _
"" & @CRLF & _
"Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?" & @CRLF & _
"Собственно, если определённый список строк в формате:" & @CRLF & _
"строка значение" & @CRLF & _
"Одно от другого разделено табом. " & @CRLF & _
"Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении." & @CRLF & _
"Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")