import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?![^а-я]+строк[^а-я]+).)*$";
final String string = "только чистое слово: строк или \"строк\"\n"
+ "А ниже слова содержащие слово \"строк\" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:\n\n"
+ "Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?\n"
+ "Собственно, если определённый список строк в формате:\n"
+ "строка значение\n"
+ "Одно от другого разделено табом. \n"
+ "Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.\n"
+ "Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}