const regex = new RegExp('^(?>(?![^а-я]+строк[^а-я]+).)*$', 'gm')
const str = `только чистое слово: строк или "строк"
А ниже слова содержащие слово "строк" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:
Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?
Собственно, если определённый список строк в формате:
строка значение
Одно от другого разделено табом.
Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.
Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}