# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(?![^а-я]+строк[^а-я]+).)*$"
test_str = ("только чистое слово: строк или \"строк\"\n"
"А ниже слова содержащие слово \"строк\" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:\n\n"
"Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?\n"
"Собственно, если определённый список строк в формате:\n"
"строка значение\n"
"Одно от другого разделено табом. \n"
"Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.\n"
"Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.