$re = '`^(?>(?![^а-я]+строк[^а-я]+).)*$`m';
$str = 'только чистое слово: строк или "строк"
А ниже слова содержащие слово "строк" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:
Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?
Собственно, если определённый список строк в формате:
строка значение
Одно от другого разделено табом.
Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.
Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);