use strict;
my $str = 'только чистое слово: строк или "строк"
А ниже слова содержащие слово "строк" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:
Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?
Собственно, если определённый список строк в формате:
строка значение
Одно от другого разделено табом.
Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.
Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.
';
my $regex = qr`^(?>(?![^а-я]+строк[^а-я]+).)*$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}