import Foundation
let pattern = #"^(?>(?![^а-я]+строк[^а-я]+).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
только чистое слово: строк или "строк"
А ниже слова содержащие слово "строк" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:
Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?
Собственно, если определённый список строк в формате:
строка значение
Одно от другого разделено табом.
Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.
Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)