using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>(?![^а-я]+строк[^а-я]+).)*$";
string input = @"только чистое слово: строк или ""строк""
А ниже слова содержащие слово ""строк"" в составе (т.е перед или после слова находится буква). И такие мы посчитаем как не соответсвующие задаче. И эти строки выделятся как не найденные:
Каким образом с помощью регулярных выражений выделить все строки, в которых отсутствует определённое слов?
Собственно, если определённый список строк в формате:
строка значение
Одно от другого разделено табом.
Необходимо удалить все строки, которые не содержат определённого шаблона в регулярном выражении.
Про (?!:...) и ему подобные я наслышан, но как бы не пытался их прописывать - результата этого не даёт.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}