# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s*?\$[^=]+=\s*explode.*?)\);$/$1 ?? '');/gm;t' <<< "$data = explode(\"|\", $file[0]);
$xdata = explode(\"|\", $xfile[1]);
$ydata = explode(\"|\", $yfile[2]);
"