re = /^(\s*?\$[^=]+=\s*explode.*?)\);$/m
str = '$data = explode("|", $file[0]);
$xdata = explode("|", $xfile[1]);
$ydata = explode("|", $yfile[2]);
'
subst = '$1 ?? \'\');'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result