$re = '/^(\s*?\$[^=]+=\s*explode.*?)\);$/m';
$str = '$data = explode("|", $file[0]);
$xdata = explode("|", $xfile[1]);
$ydata = explode("|", $yfile[2]);
';
$subst = "$1 ?? '');";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;