using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*?\$[^=]+=\s*explode.*?)\);$";
string substitution = @"$1 ?? '');";
string input = @"$data = explode(""|"", $file[0]);
$xdata = explode(""|"", $xfile[1]);
$ydata = explode(""|"", $yfile[2]);
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}