// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s*?\$[^=]+=\s*explode.*?)\);$").unwrap();
let string = "$data = explode(\"|\", $file[0]);
$xdata = explode(\"|\", $xfile[1]);
$ydata = explode(\"|\", $yfile[2]);
";
let substitution = "$1 ?? '');";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}