use strict;
my $str = '$data = explode("|", $file[0]);
$xdata = explode("|", $xfile[1]);
$ydata = explode("|", $yfile[2]);
';
my $regex = qr/^(\s*?\$[^=]+=\s*explode.*?)\);$/mp;
my $subst = '$1 ?? \'\');';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";