const regex = /^(\s*?\$[^=]+=\s*explode.*?)\);$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*?\\$[^=]+=\\s*explode.*?)\\);$', 'gm')
const str = `\$data = explode("|", \$file[0]);
\$xdata = explode("|", \$xfile[1]);
\$ydata = explode("|", \$yfile[2]);
`;
const subst = `$1 ?? '');`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);