#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*?\$[^=]+=\s*explode.*?)\);$"
Local $sString = "$data = explode("|", $file[0]);" & @CRLF & _
"$xdata = explode("|", $xfile[1]);" & @CRLF & _
"$ydata = explode("|", $yfile[2]);" & @CRLF & _
""
Local $sSubst = "$1 ?? '');"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)