# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\]\()https:\/\/github\.com\/[^\\/]+\/[^\\/]+\/(?:issues|pull)\/(\d+)/[#$1]($0)/gm;t' <<< "- Should convert: https://github.com/versionpress/versionpress/issues/123
- Should convert: https://github.com/versionpress/versionpress/pull/123
- Should convert: (https://github.com/versionpress/versionpress/issues/123)
- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)
"