use strict;
my $str = '- Should convert: https://github.com/versionpress/versionpress/issues/123
- Should convert: https://github.com/versionpress/versionpress/pull/123
- Should convert: (https://github.com/versionpress/versionpress/issues/123)
- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)
';
my $regex = qr@(?<!\]\()https://github\.com/[^\/]+/[^\/]+/(?:issues|pull)/(\d+)@mp;
my $subst = '[#$1]($0)';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";