const regex = new RegExp('(?<!\\]\\()https://github\\.com/[^\\/]+/[^\\/]+/(?:issues|pull)/(\\d+)', 'gm')
const str = `- Should convert: https://github.com/versionpress/versionpress/issues/123
- Should convert: https://github.com/versionpress/versionpress/pull/123
- Should convert: (https://github.com/versionpress/versionpress/issues/123)
- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)
`;
const subst = `[#$1]($0)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);