#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\]\()https://github\.com/[^\/]+/[^\/]+/(?:issues|pull)/(\d+)"
Local $sString = "- Should convert: https://github.com/versionpress/versionpress/issues/123" & @CRLF & _
"- Should convert: https://github.com/versionpress/versionpress/pull/123" & @CRLF & _
"- Should convert: (https://github.com/versionpress/versionpress/issues/123)" & @CRLF & _
"- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)" & @CRLF & _
""
Local $sSubst = "[#$1]($0)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)