$re = '@(?<!\]\()https://github\.com/[^\/]+/[^\/]+/(?:issues|pull)/(\d+)@m';
$str = '- Should convert: https://github.com/versionpress/versionpress/issues/123
- Should convert: https://github.com/versionpress/versionpress/pull/123
- Should convert: (https://github.com/versionpress/versionpress/issues/123)
- Should NOT convert (already a Markdown link): [#123](https://github.com/versionpress/versionpress/issues/123)
';
$subst = "[#$1]($0)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;