using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(as|aox)\d+\.vs-prod-domain\.com";
string input = @"as01.vs-prod-domain.com
as02.vs-prod-domain.com
aox01.vs-prod-domain.com
aox02.vs-prod-domain.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}