import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(as|aox)\\d+\\.vs-prod-domain\\.com";
final String string = "as01.vs-prod-domain.com\n"
+ "as02.vs-prod-domain.com\n"
+ "aox01.vs-prod-domain.com\n"
+ "aox02.vs-prod-domain.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}