import re
regex = re.compile(r"(as|aox)\d+\.vs-prod-domain\.com", flags=re.MULTILINE)
test_str = ("as01.vs-prod-domain.com\n"
"as02.vs-prod-domain.com\n"
"aox01.vs-prod-domain.com\n"
"aox02.vs-prod-domain.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")