// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(as|aox)\d+\.vs-prod-domain\.com").unwrap();
let string = "as01.vs-prod-domain.com
as02.vs-prod-domain.com
aox01.vs-prod-domain.com
aox02.vs-prod-domain.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}