re = /(as|aox)\d+\.vs-prod-domain\.com/m
str = 'as01.vs-prod-domain.com
as02.vs-prod-domain.com
aox01.vs-prod-domain.com
aox02.vs-prod-domain.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end