$re = '/(as|aox)\d+\.vs-prod-domain\.com/m';
$str = 'as01.vs-prod-domain.com
as02.vs-prod-domain.com
aox01.vs-prod-domain.com
aox02.vs-prod-domain.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);