#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b"
Local $sString = "22998677402" & @CRLF & _
"2225235564" & @CRLF & _
"25348738" & @CRLF & _
"97476234" & @CRLF & _
"997346573" & @CRLF & _
"outracoisa" & @CRLF & _
"sdfsdfsdfs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")