using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b";
string input = @"22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}