// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b").unwrap();
let string = "22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}