$re = '/\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b/';
$str = '22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);