const regex = /\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{2}([8-9]\\d{8}|[1-7]\\d{7})\\b', 'g')
const str = `22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}