use strict;
my $str = '22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs';
my $regex = qr/\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}