package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d{2}([8-9]\d{8}|[1-7]\d{7})\b`)
var str = `22998677402
2225235564
25348738
97476234
997346573
outracoisa
sdfsdfsdfs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}