import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{2}([8-9]\\d{8}|[1-7]\\d{7})\\b";
final String string = "22998677402\n"
+ "2225235564\n"
+ "25348738\n"
+ "97476234\n"
+ "997346573\n"
+ "outracoisa\n"
+ "sdfsdfsdfs";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}